API setup issues

Hey everyone, Im trying to setup the autotrade but running into issues. I’m on a Mac and I’m still a novice when it comes to Java. When setting up I’ve made sure that im using the correct info however sometimes it will say incorrect password or username. also, when it doesn’t say that I get met with this error.

Also not sure if this has to do with Mac but when I use the yarn commands, it says no such command exists so I have to use npm


Screen Shot 2022-01-18 at 6.53.40 PM

You could probably get yarn by going to your console and typing npm install yarn -g.

What endpoint are you looking at for HTTP_URL in index.js?

Thanks that worked for yarn, as for end points, right now its my demo account so I can test and see how it executes

Screen Shot 2022-01-20 at 10.37.58 PM

I solved my issue by creating another API Key with the same permissions but the difference this time being that I didnt use a password on the API itself. Not sure why this fixed it but it works and I wanted to share incase anyone else comes across this problem.

When you were using an API Key with a dedicated password, were you using the password you set as the key’s dedicated password, or were you using the password for your user?