Trouble placing orders w/ the API

Hello there,

I am using /order/placeorder
You can check my request body in the attached image

I have already given full permission to orders in the api

I have tried getting token from both and

All read apis are working but write apis are not working

I am getting this response
{‘failureReason’: ‘UnknownReason’, ‘failureText’: ‘Access is denied’}
with 200 Response code

I know you said you’ve given Full Access to Orders in your API key, but please check your other permissions as well. You will also need to grant Read access to the Contract Library so that the server can look up the contract you’re attempting to trade.

Thanks for the quick reply! Please view the screens capture of my Permissions. I’ve given full permission to all except user info. I even created a second API key w/ the same permissions and same issue w/ that one too

The demo- and live- endpoints have been discontinued in favor of the universal namespace. Now, all API endpoints should be or Did you try sending the request with that base-URL as well?


I’ve tried both base URL’s and no luck still …any ideas?

Anybody have a solution? Seems like a lot of people are running into the same issue

I believe you need to include your submit method via POST along with the URL, header and body.

None of this has helped…does anyone have any solutions? Seems a bit crazy that I can’t get this to work…I got my Interactive Brokers API to auto trade in a matter of 1-2 days.

See what happens if you change the Your User Information setting on your API key to ‘Read only’.

This is how I am fetching device id and then access token.
Access token is fetched and I am able to access the positions using that access token.
I’ve given full access to all parameters in the API key…I’m not really sure what is going on at this point…

Are you able to access a different post endpoint, like /cashBalance/getcashbalancesnapshot?

The problem has been solved. I was using a developer to build this out and I “DENIED” User information (just to protect my personal information). For those in the future having this issue: make sure it says “FULL ACCESS”, as it will show you the true account ID.

I gave full access and he was able to immediately get it to work…we placed live trades and it works.

1 Like