I am not able to get Symbol Data

I am unable to receive data for NQZ2. I was getting the data for past 4 months. But suddently stopped and hour ago… This is the error I am getting
{{
“errorText”: “Symbol is inaccessible”,
“errorCode”: “UnknownSymbol”,
“mode”: “None”
}}

This is the request sent -
md/getChart
1

{“symbol”:“NQZ2”,“chartDescription”:{“underlyingType”:“Tick”,“elementSizeUnit”:“UnderlyingUnits”,“elementSize”:1,“withHistogram”:false},“timeRange”:{“asMuchAsElements”:5000}}

6 Likes

I’m having the same issue this morning. It was working last night, but when I tried fetching market data, it failed with the same error message.

2 Likes

I’m running up against the same

1 Like

Yeah, I have the same issue here

Having the same issue…

1 Like

SAME! i need this to work

1 Like

I’m having the same problem

1 Like

I also notice while SSL sniffing the desktop app, that the format for market data has changed… so not sure what it going on here.

2 Likes

Apparently, they need some license/verification form to be filled for CME. Unfortunately, they said that they send the email but I don’t get any email about it from them. Not sure who long will it take to get that form to be approved.

1 Like

how did u find this out? i notice the desktop app still works… and it is querying market data… just different format than i expect. and the subscribeqoute call isn’t erroring

1 Like

Yeah. Its a special requirement for API users.

1 Like

As in, tradovate was supposed to forward a form on behalf of CME? No email for me either.

1 Like

I had the same issue and no email, but there was a new agreement to sign when I checked under settings/subscriptions in the desktop app…

1 Like

has anyone been able to solve this? I checked for a new agreement and still can’t get market data.

Chat support told me I had to go to CME and be registered as a “data distributor” and gave me this link: https://www.cmegroup.com/market-data/license-data.html

I cannot for the life of me imagine out how this is supposed to work, or which thing I need to actually register for, but it’s what I was given from support today. Seems odd.
image

1 Like

@kedzietrades can you elaborate on what the new format should be?

1 Like

Hmm, I don’t think that sounds right- a data distribution license provides:

authorization to provide subscription-based services for CME market data

which I assume you’re not doing as a non-commercial client of tradovate.

Unless tradovate has new restrictions on api access? I have not seen this communicated anywhere.

1 Like

Maybe this? https://www.cmegroup.com/market-data/distributor/files/exhibit-a-to-schedule-4-non-pro-self-cert-form.pdf

If you’re a non-commercial user, it says to fill it out and present it to your data provider.

1 Like

If you have been using the tradovate api for futures data already, you’ve likely already completed this form. Check under Your ProfileSigned Documents

The “Non-Professional Market Data Certification” is the CME’s form.

Despite that form, I’m still getting errors.

1 Like

I’m seeing this as well for ESZ2 as of 3:10PM EST.

1 Like