Extended Tick Data Seems Useless

I’m paying monthly for this data feed, but it is not accurate at all. Please see the following image. Once the contract rollover took place a couple of weeks ago in June, the volume data from the previous contract is completely inaccurate(red circle). It only takes into account the current contract and ignores the previous, but somehow calculates volume from other earlier contracts.

Secondly, in the blue circle you can see that this data is incomplete. It appears to start to get inaccurate in March and then gets really bad in January.

A few notes:
I use 24 hour candles via the custom time (1440 minutes) option for candles, not the day preset. My candle data needs to start at 5pm CST, not midnight, because that is how the futures markets operate. The day preset has the same volume problem as well anyway.

I use TAS Market Profile for volume analysis. The built in Volume Profile indicator suffers from the same problem. This is not a problem with the TAS indicators.

I’m filing this under a feature request because I don’t think this was a consideration at all. I don’t think it’s a bug.

You can see how bad this is if you compare it to a different trading software. Price on the Russell is between two main points of control this morning and I can guarantee with high probability it will interact with those levels at some point today. Tradovate isn’t showing the points of control correctly and in turn would affect my trading strategy.

Correct Data, other platform:

Broken data on Tradovate:

You can see how inaccurate the second most recent profile is. This is when the contract rolled over. That is an important data point since it is more recent. I can’t even get the oldest profile to show up in Tradovate since there is no accurate data. The Extended Tick Data package claims it provides a year of data. I can’t even get an accurate 6 months out of it.

I just want to be sure:

Are you comparing a “continuous” contract in another platform to a contract with an expiration in Tradovate (rather than the continuous contract in Tradovate)?

I’m just typing in 1440 minutes in both platforms. I didn’t know there was a continuous option in Tradovate. The other platform seems to automatically apply that. I’m using M2KU1 to view this in Tradovate.

I can’t find the continuous contract. What is it called?

In Tradovate the continuous contracts are prefixed with the “@” symbol, so you could pull up a chart for @M2K and compare

1 Like

Thanks, but it only goes back to June 10th so it’s actually worse.

The above is for 1440 minutes. the Day option works as expected. I want it the candle to start at 5pm CST and end at 5PM the next day. I’ll keep investigating this today.

This is workable. Thank you for pointing out my error. I’m glad I asked.

1 Like